BSCI: OSPF – Network types

OSPF contient plusieurs types de réseaux:

  • Broadcast multiaccess
  • Point-to-point
  • Point-to-multipoint
  • NBMA (Non-broadcast multiaccess)
NonBroadcast Point-to-multipoint
(broadcast)
Point-to-multipoint
(non broadcast)
Broadcast Point-to-point
DR/BDR YES NO NO YES NO
Identify neighbor? YES NO YES NO NO
Time Interval (Hello/Dead) 30/120 30/120 30/120 10/40 10/40
RFC 2328 RFC RFC Cisco Cisco Cisco
Network Supported Full Mesh Any Any Full Mesh Point-to-point

Point-to-point

Le réseau le plus simple, un lien entre deux routeurs.

Broadcast

Les réseaux broadcast sont des réseaux « MultiAccess », c’est à dire que le segment contient plusieurs end-points . Voici ci-dessous un exemple de segment Ethernet.

Les réseaux Ethernet supportent le Broadcast, un paquet transmit par un équipement peut être multiplié grâce ici à un switch et tous les end-points qui reçoivent une copie de ce paquet. Avantageux sur la bande passante, et facilite la découverte de voisins. (Les routeurs OSPF annoncent sur l’adresse broadcast 224.0.0.5)

Les routeurs OSPF dans un réseau Broadcast élisent un DR (Designated Router) et un BDR (Backup Designated Router).

Configuration du réseau OSPF Broadcast

Router(config)#interface FastEthernet 0
Router(config-if)#ip address 10.1.1.1 255.255.255.0
Router(config-if)#ip ospf network broadcast

Router(config)#router ospf 1
Router(config-router)#network 10.1.1.0 0.0.0.255 area 0

Non Broadcast

Toutes les technologies ne supportent pas la transmission Broadcast. (Frame Relay et ATM par exemple). Ces réseaux requièrent des PVC (Permanent virtual Circuits) configurés entre les end-points.

Configuration du réseau OSPF NonBroadcast

Router(config)#interface Serial0
Router(config-if)#ip address 10.1.1.1 255.255.255.0
Router(config-if)#encapsulation frame-relay

Router(config)#router ospf 1
Router(config-router)#network 10.1.1.0 0.0.0.255 area 0
Router(config-router)#neighbor 10.1.1.2
Router(config-router)#neighbor 10.1.1.3
Router(config-router)#neighbor 10.1.1.4

Non-Broadcast Multi-Access (NBMA)

Un segment NBMA émule la fonction de réseau Broadcast. Chaque routeur sur chaque segment doit être configuré avec les adresses IP de tous ses voisins.
Comme dans un vrai réseau Broadcast, un DR et un BDR sont élus pour limiter le nombre d’adjacences.

Point-to-Multipoint

Les réseaux Point-to-multipoint gère les limitation des réseaux non-broadcast différemment des réseaux NBMA. Plutôt que d’émuler le broadcast, Ils organisent les PVCs en plusieurs réseaux Point-to-Point. Il n’y à donc pas d’élection de DR/BDR.

Benoit

Network engineer CCIE #47705, focused on R&S, Data Center and SDN.

More Posts - Website

Follow Me:
TwitterLinkedIn

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Vous pouvez utiliser ces balises et attributs HTML : <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>