BSCI: LAB EIGRP – Summarization

Voyons comment se comporte EIGRP avec les summary, nous allons voir comment configurer l’auto-summarization, ou la non auto-summarization, en automatique, ou en manuel avec les commandes adéquat.

Nous allons utiliser la topologie suivante:
bsci eigrp summarisation

Configuration des deux routeurs:

R1:

hostname R1
!
router eigrp 100
network 10.0.0.0
network 192.168.200.0
auto-summary
!
interface Loopback1
ip address 192.168.200.1 255.255.255.252
!
interface Loopback2
ip address 192.168.200.5 255.255.255.252
!
interface Loopback3
ip address 192.168.200.9 255.255.255.252
!
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.0
duplex auto
speed auto
!
end

R3:

hostname R3
!
router eigrp 100
network 10.0.0.0
network 192.168.0.0
auto-summary
!
interface Loopback1
ip address 192.168.0.1 255.255.255.0
!
interface Loopback2
ip address 192.168.1.1 255.255.255.0
!
interface Loopback3
ip address 192.168.3.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.0.0.3 255.255.255.0
duplex auto
speed auto
!
end

EIGRP Auto Summarization

Nous voyons la configuration IP de R1:

R1#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.0.0.1        YES manual up                    up
Loopback1                  192.168.200.1   YES manual up                    up
Loopback2                  192.168.200.5   YES manual up                    up
Loopback3                  192.168.200.9   YES manual up                    up

Nous avons trois Loopback, soit 3 réseaux.
En mode par défaut, EIGRP est configuré en auto-summary, c’est à dire qu’il diffusera un summary de ses routes aux autres routeurs. Le summary de nos 3 loopback est 192.168.200.0/24. R1 Diffuse donc sa topologie en n’annoncant que la route 192.168.200.0/24. L’avantage du summary est qu’avec un réseau hiérarchisé, les routeurs n’ont pas besoin d’annoncer toutes leurs routes une par une et économisent de la mémoire (Table de routage) et du CPU.

bsci eigrp summarisation

Mais nous pouvons demander à EIGRP de ne pas créer de summary automatiquement, avec la commande « no auto-summary » . Dans ce cas, il diffusera chaque loopback une par une, 192.168.200.1/30, 192.168.200.5/30 et 192.168.200.9/30.

bsci eigrp summarisation

Voici concrètement ce qu’il se passe sur notre routeur R1:

R1(config)#router eigrp 100
!auto-summary
R1(config-router)#auto-summary
*Jan 14 20:33:37.778: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.0.0.3 (FastEthernet0/0) is resync: summary configured
*Jan 14 20:33:37.778: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.0.0.2 (FastEthernet0/0) is resync: summary configured
R1(config-router)#

!no auto-summary
R1(config-router)#no auto-summary
R1(config-router)#
*Jan 14 20:38:49.242: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.0.0.3 (FastEthernet0/0) is resync: summary configured
*Jan 14 20:38:49.242: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.0.0.2 (FastEthernet0/0) is resync: summary configured

Voici concrètement ce qu’il se passe sur notre routeur R3:

! pendant le auto-summary

R3#deb ip eigrp 100
IP-EIGRP Route Events debugging is on
R3#deb ip eigrp summary
IP-EIGRP Summary route processing debugging is on
R3#
*Jan 14 21:50:34.229: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.0.0.1 (FastEthernet0/0) is resync: peer graceful-restart
*Jan 14 21:50:34.229: IP-EIGRP(Default-IP-Routing-Table:100): Processing incoming UPDATE packet
*Jan 14 21:50:34.241: IP-EIGRP(Default-IP-Routing-Table:100): Processing incoming UPDATE packet
*Jan 14 21:50:34.241: IP-EIGRP(Default-IP-Routing-Table:100): Int 192.168.200.0/24 M 156160 - 25600 130560 SM 128256 - 256 128000
*Jan 14 21:50:34.241: IP-EIGRP(Default-IP-Routing-Table:100): route installed for 192.168.200.0  ()
*Jan 14 21:50:34.241: IP-EIGRP(Default-IP-Routing-Table:100): Int 10.0.0.0/8 M 4294967295 - 25600 4294967295 SM 4294967295 - 25600 4294967295
[...]

! pendant le no auto-summary

R3#deb ip eigrp 100
IP-EIGRP Route Events debugging is on
R3#deb ip eigrp summary
IP-EIGRP Summary route processing debugging is on
R3#
*Jan 14 21:49:48.701: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.0.0.1 (FastEthernet0/0) is resync: peer graceful-restart
*Jan 14 21:49:48.701: IP-EIGRP(Default-IP-Routing-Table:100): Processing incoming UPDATE packet
*Jan 14 21:49:48.701: IP-EIGRP(Default-IP-Routing-Table:100): Int 192.168.200.0/30 M 156160 - 25600 130560 SM 128256 - 256 128000
*Jan 14 21:49:48.701: IP-EIGRP(Default-IP-Routing-Table:100): route installed for 192.168.200.0  ()
*Jan 14 21:49:48.701: IP-EIGRP(Default-IP-Routing-Table:100): Int 192.168.200.4/30 M 156160 - 25600 130560 SM 128256 - 256 128000
*Jan 14 21:49:48.701: IP-EIGRP(Default-IP-Routing-Table:100): route installed for 192.168.200.4  ()
*Jan 14 21:49:48.705: IP-EIGRP(Default-IP-Routing-Table:100): Int 192.168.200.8/30 M 156160 - 25600 130560 SM 128256 - 256 128000
*Jan 14 21:49:48.705: IP-EIGRP(Default-IP-Routing-Table:100): route installed for 192.168.200.8  ()
*Jan 14 21:49:48.709: IP-EIGRP(Default-IP-Routing-Table:100): Processing incoming QUERY packet
*Jan 14 21:49:48.709: IP-EIGRP(Default-IP-Routing-Table:100): Int 192.168.200.0/24 M 4294967295 - 0 4294967295 SM 4294967295 - 0 4294967295
*Jan 14 21:49:48.709: IP-EIGRP(Default-IP-Routing-Table:100): Int 10.0.0.0/8 M 4294967295 - 0 4294967295 SM 4294967295 - 0 4294967295
[...]

Voici maintenant une vue des routes sur R3:

!Auto-Summary
R3#sh ip route eigrp
D    192.168.200.0/24 [90/156160] via 10.0.0.1, 00:05:04, FastEthernet0/0

!no auto-summary
! R1 diffuse maintenant toute ses routes, une par une
R3#show ip route eigrp
192.168.200.0/30 is subnetted, 3 subnets
D       192.168.200.0 [90/156160] via 10.0.0.1, 00:00:06, FastEthernet0/0
D       192.168.200.4 [90/156160] via 10.0.0.1, 00:00:06, FastEthernet0/0
D       192.168.200.8 [90/156160] via 10.0.0.1, 00:00:06, FastEthernet0/0

EIGRP Manual Summarization

Les summary sont fait en se basant sur les interfaces. Que ce soit manuellement, ou automatiquement, EIGRP se base sur les interfaces pour générer le summary. Bien que auto-summary active l’auto-summaryzation sur tout le routeur, nous pouvons configurer des summary manuels à l’aide de la commande ip summary-address eigrp AS network mask.

La commande suivante produira le même effet que si nous avions configuré EIGRP en auto-summary:

R1(config)#interface fastethernet 0/0
R1(config-if)#ip summary-address eigrp 100 192.168.200.0 255.255.255.0

Benoit

Network engineer CCIE #47705, focused on R&S, Data Center and SDN.

More Posts - Website

Follow Me:
TwitterLinkedIn

2 Comments

  1. TIEMOKO 18 mars 2010

    je prépare mon CCIP,j’ai besoin de de la documentation en BSCI,QoS,MPLS et BGP.

  2. Benoit 18 mars 2010

    Bonjour,
    Tu à quelques labs BSCI sur ce blog,
    sinon je t’invite à suivre ce lien, ou tu pourra trouver toute la doc qu’il te faudra : http://www.ciscopress.com/bookstore/browse.asp?st=42140
    Good luck !

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Vous pouvez utiliser ces balises et attributs HTML : <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>