Remplacer sa Freebox par un routeur CISCO

Voici une configuration basique afin de pouvoir remplacer sa Freebox par un vrai routeur .

  • Connexion ATM vers le DSLAM Free
  • Route par défaut forcée vers l’interface ATM0.1 –> Free
  • Adresse IP LAN (ethernet0) en 192.168.0.1/24
  • Translation d’adresse (PAT) entre l’interface LAN et l’interface ADSL

Configuration:

!
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Freebox
!
enable secret 5 $1$G81D$tAJ.P.HiCKV6Xh*******.
!
username networklife privilege 15 secret 5 $1$h1R0$D********
ip subnet-zero
ip domain name networklife.net
!
ip dhcp pool DHCP_Lan
   network 192.168.0.0 255.255.255.0
   default-router 192.168.0.1
   dns-server 212.27.54.252 212.27.53.252
   update arp
!
ip ssh time-out 60
no aaa new-model
!
interface Ethernet0
description - Connexion au LAN -
ip address 192.168.0.1 255.255.255.0
ip nat inside
hold-queue 100 out
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
description - Connexion vers FREE -
ip address dhcp
ip nat outside
pvc 8/36
encapsulation aal5mux ip
!
!
ip nat inside source list 1 interface ATM0.1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 ATM0.1
no ip http server
!
access-list 1 permit 192.168.0.0 0.0.0.255
!
line con 0
line aux 0
!
line vty 0 4
access-class 1 in
login local
transport input ssh
!
scheduler max-task-time 5000
!
end

Pour la téléphonie, voici un article trouvé sur le net: http://www.queret.net/blog/index.php/2006/06/07/30-freebox-freephonie-sip-et-cisco-ip-phone-7940g , qui permet de configurer un téléphone IP CISCO 7900 Series avec le compte SIP de Free.

Benoit

Network engineer CCIE #47705, focused on R&S, Data Center and SDN.

More Posts - Website

Follow Me:
TwitterLinkedIn

11 Comments

  1. cpx 11 mars 2009

    ok bien et pour la telephonie?

  2. Benoit 11 mars 2009

    Et bien il n’y a plus qu’a installer un IP Phone CISCO derrière le routeur et y configurer le compte SIP de Free, j’essaye de trouver la conf à apporter et je refais un article.

  3. amateur 19 juillet 2010

    Tres bien, merci beaucoup.

  4. Guillaume 10 août 2010

    Bonjour,

    Je viens de lire ton article très bien fait sur la conf d’un routeur cisco.

    Par contre à quoi te sers la commande update arp dans ta conf DHCP.

    Merci

  5. Benoit 10 août 2010

    @Guillaume: la commande « update arp » permet de mettre en place une sorte de « sécurité » DHCP qui établie une relation entre les entrées de la table ARP et les baux DHCP en cours. C’est bien sur optionnel !

  6. jeff12300 20 décembre 2010

    Bonjour,
    j’ai bien lu la conf…c’est pas mal…peux tu par contre me dire si le boitier HD peut fonctionner avec le cisco….quels sont du coup les adaptations a apporter à la conf…

    Merci d’avance
    Jeff

  7. Benoit 20 décembre 2010

    Non, après avoir lu quelques topics sur le forum labo-cisco.com il y à quelques mois, le boitier HD ne fonctionne pas avec un routeur CISCO (cela à peut-être changé depuis..).

  8. jeff12300 20 décembre 2010

    merci pour le lien…je vais investiger…si tu as d’autres infos je suis preneur :)

    Jeff

  9. Nicolas 19 juin 2011

    J’ai procédé, mon Cisco 827 se connecte bien mais le débit est divisé par presque 2 comparé à la freebox.
    Ca viendrait de la conf ?

  10. Benoit 20 juin 2011

    Je me demande si ce n’est pas a cause du Cisco 827 qui ne ferait que de l’ADSL et pas de l’ADSL 2+ ?

  11. Si 1 novembre 2011

    Comment la freebox gère la QoS de la téléphonie et comment faire sur IOS ? La téléphonie et la télévision ne sont pas sur d’autres PVC ATM ?

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Vous pouvez utiliser ces balises et attributs HTML : <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>