BSCI: LAB EIGRP – Configuration

Bienvenue dans ce nouveau Laboratoire sur EIGRP, que j’écris dans le cadre de mes révisions du CCNP BSCI. Nous allons voir la configuration de base EIGRP, suivie des commandes de vérification des 3 tables d’EIGRP (Neighbors/Topology/Routing). Les autres labs suivront dans les jours à venir…

Voici le schéma de la topologie:

Dynagen:

Fichier de topologie Dynagen .net
####
# Course: BSCI - EIGRP
# Author: Benoit GONCALVES
# Version: 1.1
###

autostart = True

[localhost:7200]
[[7200]]

[[ROUTER R1]]
image = c7200-adventerprisek9-mz.124-15.T6.bin
cnfg = R1.txt
npe = npe-400
ram = 160
nvram = 256
mmap = False
console = 2002
# modules/slots
# cabling
S1/0 = R2 S1/0
F0/0 = S1 1

[[ROUTER R2]]
image = c7200-adventerprisek9-mz.124-15.T6.bin
cnfg = R2.txt
npe = npe-400
ram = 160
nvram = 256
mmap = False
console = 2003
# modules/slots
# cabling
F0/0 = S1 3

[[ROUTER R3]]
image = c7200-adventerprisek9-mz.124-15.T6.bin
cnfg = R3.txt
npe = npe-400
ram = 160
nvram = 256
mmap = False
console = 2004
# modules/slots
# cabling
F0/0 = S1 5

[[ETHSW S1]]
1 = access 1
3 = access 1
5 = access 1

R1.txt

!
no ip domain lookup
no ip http server
!
hostname R1
!
interface Loopback1
ip address 10.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.100.1 255.255.255.0
no shutdown
!
!
interface Serial 1/0
bandwidth 64
ip address 10.1.200.1 255.255.255.0
clockrate 64000
no shutdown
!
router eigrp 1
network 10.0.0.0
auto-summary
!
end

R2.txt

no ip domain lookup
no ip http server
!
hostname R2
!
interface Loopback2
ip address 10.1.2.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.100.2 255.255.255.0
no shutdown
!
interface Serial 1/0
bandwidth 64
ip address 10.1.200.2 255.255.255.0
no shutdown
!
router eigrp 1
network 10.0.0.0
auto-summary
!
end

R3.txt

no ip domain lookup
no ip http server
!
hostname R3
!
interface Loopback3
ip address 10.1.3.1 255.255.255.0
!
interface Loopback11
ip address 192.168.100.1 255.255.255.252
!
interface Loopback15
ip address 192.168.100.5 255.255.255.252
!
interface FastEthernet0/0
ip address 10.1.100.3 255.255.255.0
no shutdown
!
!
router eigrp 1
network 10.0.0.0
network 192.168.100.0 0.0.0.3
auto-summary
!
end

Pour configurer EIGRP, rien de plus simple:

! On active le processus EIGRP dans l'Autonomous Système 1
R1(config)#router eigrp 1
! EIGRP sera actif sur le réseau 10.0.0.0, soit toute nos interfaces sur R1
R1(config-router)#network 10.0.0.0

Maintenant que vous avez tout bien configuré, Voici un debug paquet qui montre les Paquets HELLO, ACK et UPDATES envoyés et reçus quand on active EIGRP. EIGRP commence par envoyer des paquets HELLO et en reçois de ses voisins, ainsi, il forme la table d’adjacence/voisinage (neighbor table). Ensuite les routeurs s’envoient leurs tables de routages afin d’avoir une vue partielle de la topologie avoisinante.

R2#deb eigrp packet
EIGRP Packets debugging is on
    (UPDATE, REQUEST, QUERY, REPLY, HELLO, IPXSAP, PROBE, ACK, STUB, SIAQUERY, S
IAREPLY)
R2#
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#
R2(config)#router eigrp 1
R2(config-router)#network 10.0.0.0
R2(config-router)#
*Jan 12 22:03:44.279: EIGRP: Sending HELLO on FastEthernet0/0
*Jan 12 22:03:44.279:   AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Jan 12 22:03:44.287: EIGRP: Sending HELLO on Loopback2
*Jan 12 22:03:44.287:   AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Jan 12 22:03:44.299: EIGRP: Received HELLO on Loopback2 nbr 10.1.2.1
*Jan 12 22:03:44.303:   AS 1, Flags 0x0, Seq 0/0 idbQ 0/0
*Jan 12 22:03:44.303: EIGRP: Packet from ourselves ignored
*Jan 12 22:03:44.491: EIGRP: Received HELLO on FastEthernet0/0 nbr 10.1.100.1
*Jan 12 22:03:44.491:   AS 1, Flags 0x0, Seq 0/0 idbQ 0/0

*Jan 12 22:03:44.499: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.100.1 (FastEthernet0/0) is up: new adjacency

*Jan 12 22:03:44.503: EIGRP: Enqueueing UPDATE on FastEthernet0/0 nbr 10.1.100.1 iidbQ un/rely 0/1 peerQ un/rely 0/0
*Jan 12 22:03:44.507: EIGRP: Requeued unicast on FastEthernet0/0
*Jan 12 22:03:44.511: EIGRP: Forcing multicast xmit on FastEthernet0/0

*Jan 12 22:03:44.515: EIGRP: Sending UPDATE on FastEthernet0/0 nbr 10.1.100.1
*Jan 12 22:03:44.519:   AS 1, Flags 0x1, Seq 1/0 idbQ 3/0 iidbQ un/rely 0/0 peerQ un/rely 0/1
*Jan 12 22:03:44.523: EIGRP: Enqueueing UPDATE on FastEthernet0/0 iidbQ un/rely0/1 serno 1-2
*Jan 12 22:03:44.527: EIGRP: Building Sequence TLV
*Jan 12 22:03:44.531: EIGRP: Enqueueing UPDATE on FastEthernet0/0 nbr 10.1.100.1 iidbQ un/rely 0/0 peerQ un/rely 0/1 serno 1-2
*Jan 12 22:03:44.535: EIGRP: Sending HELLO with Sequence TLV on FastEthernet0/0, seq 2
*Jan 12 22:03:44.587: EIGRP: Received Sequence TLV from 10.1.100.1
*Jan 12 22:03:44.591:        10.1.100.2
*Jan 12 22:03:44.591:        address matched
*Jan 12 22:03:44.595:        clearing CR-mode
*Jan 12 22:03:44.595: EIGRP: Received CR sequence TLV from 10.1.100.1, sequence2

*Jan 12 22:03:46.523: EIGRP: Sending UPDATE on FastEthernet0/0 nbr 10.1.100.1, retry 1, RTO 3000
*Jan 12 22:03:46.527:   AS 1, Flags 0x1, Seq 1/1 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/2
*Jan 12 22:03:46.683: EIGRP: Received UPDATE on FastEthernet0/0 nbr 10.1.100.1
*Jan 12 22:03:46.687:   AS 1, Flags 0x8, Seq 2/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/2
*Jan 12 22:03:46.843: EIGRP: Received ACK on FastEthernet0/0 nbr 10.1.100.1
*Jan 12 22:03:46.847:   AS 1, Flags 0x0, Seq 0/1 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/2
*Jan 12 22:03:46.855: EIGRP: Sending UPDATE on FastEthernet0/0 nbr 10.1.100.1
*Jan 12 22:03:46.855:   AS 1, Flags 0x8, Seq 2/2 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1 serno 1-2
*Jan 12 22:03:47.139: EIGRP: Received UPDATE on FastEthernet0/0 nbr 10.1.100.1

*Jan 12 22:03:47.143:   AS 1, Flags 0x8, Seq 3/1 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1
*Jan 12 22:03:47.147: EIGRP: Enqueueing ACK on FastEthernet0/0 nbr 10.1.100.1
*Jan 12 22:03:47.151:   Ack seq 3 iidbQ un/rely 0/0 peerQ un/rely 1/1
*Jan 12 22:03:47.155: EIGRP: Sending ACK on FastEthernet0/0 nbr 10.1.100.1
*Jan 12 22:03:47.159:   AS 1, Flags 0x0, Seq 0/3 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 1/1
*Jan 12 22:03:47.195: EIGRP: Received ACK on FastEthernet0/0 nbr 10.1.100.1
*Jan 12 22:03:47.199:   AS 1, Flags 0x0, Seq 0/2 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1

Maintenant un output des commandes de bases sur la visualisation de notre topologie EIGRP:

R1#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.1.100.1      YES manual up                    up
FastEthernet0/1            unassigned      YES unset  administratively down down
Serial1/0                  10.1.200.1      YES manual up                    up
Loopback1                  10.1.1.1        YES NVRAM  up                    up

R1#sh ip ei neighbor
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   10.1.100.2              Fa0/0             10 00:00:13   72   432  0  66
0   10.1.100.3              Fa0/0             10 00:00:14  233  1398  0  42
2   10.1.200.2              Se1/0             14 00:58:23  304  2280  0  65

R1#sh ip ei topology
IP-EIGRP Topology Table for AS(1)/ID(10.1.1.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.1.3.0/24, 1 successors, FD is 156160
        via 10.1.100.3 (156160/128256), FastEthernet0/0
P 10.1.2.0/24, 1 successors, FD is 156160
        via 10.1.100.2 (156160/128256), FastEthernet0/0
        via 10.1.200.2 (40640000/128256), Serial1/0
P 10.1.1.0/24, 1 successors, FD is 128256
        via Connected, Loopback1
P 192.168.100.0/24, 1 successors, FD is 156160
        via 10.1.100.3 (156160/128256), FastEthernet0/0
P 10.1.100.0/24, 1 successors, FD is 28160
        via Connected, FastEthernet0/0
P 10.1.200.0/24, 1 successors, FD is 40512000
        via Connected, Serial1/0

R1#sh ip ei traffic
IP-EIGRP Traffic Statistics for AS 1
  Hellos sent/received: 2265/2747
  Updates sent/received: 70/57
  Queries sent/received: 16/6
  Replies sent/received: 7/21
  Acks sent/received: 68/76
  SIA-Queries sent/received: 0/0
  SIA-Replies sent/received: 0/0
  Hello Process ID: 236
  PDM Process ID: 233
  IP Socket queue:   0/2000/5/0 (current/max/highest/drops)
  Eigrp input queue: 0/2000/5/0 (current/max/highest/drops)

R1#sh ip route eigrp
     10.0.0.0/24 is subnetted, 5 subnets
D       10.1.3.0 [90/156160] via 10.1.100.3, 00:00:27, FastEthernet0/0
D       10.1.2.0 [90/156160] via 10.1.100.2, 00:00:26, FastEthernet0/0
D    192.168.100.0/24 [90/156160] via 10.1.100.3, 00:00:27, FastEthernet0/0

On voit que l’inteface serial à une bandwidth par défaut de 1544 kbit, alors qu’on l’a clocké à 64kbps.

Etant donnée que EIGRP utilise par défaut 50% max. de la bandwidth, notre lien risque d’être vite saturé.
C’est pourquoi nous allons ajouter la ligne de commande bandwidth à l’interface pour modifier celle-ci.

R1#show interfaces serial 1/0
Serial0/0/0 is up, line protocol is up
Hardware is GT96K Serial
Internet address is 10.1.200.1/24
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
[...]

Etant donnée qu’EIGRP utilise par défaut 50% max. de la bandwidth, notre lien risque d’être vite saturé.
C’est pourquoi nous allons ajouter la ligne de commande bandwidth à l’interface pour modifier celle-ci.

R1(config)#interface Serial 1/0
R1(config-if)#bandwidth 64

R2(config)#interface Serial 1/0
R2(config-if)#bandwidth 64
R1#show interfaces serial 1/0
Serial0/0/0 is up, line protocol is up
Hardware is GT96K Serial
Internet address is 10.1.200.1/24
MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
[...]

R2#show interfaces serial 1/0
Serial0/0/0 is up, line protocol is up
Hardware is GT96K Serial
Internet address is 10.1.200.2/24
MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
[...]

##########
##########

Nous allons pinger 10.1.1.1 depuis R3 et « shutter » l’interface f0/0 de R1 entre temps.

R3#sh ip ei topology
IP-EIGRP Topology Table for AS(1)/ID(10.1.3.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - R,  r - reply Status, s - sia Status

P 10.1.3.0/24, 1 successors, FD is 128256
        via Connected, Loopback3
P 10.1.2.0/24, 1 successors, FD is 156160
        via 10.1.100.2 (156160/128256), FastEthernet0/0
P 10.0.0.0/8, 1 successors, FD is 28160
        via Summary (28160/0), Null0
P 10.1.1.0/24, 1 successors, FD is 156160
        via 10.1.100.1 (156160/128256), FastEthernet0/0
P 192.168.100.0/24, 1 successors, FD is 128256
        via Summary (128256/0), Null0
P 192.168.100.0/30, 1 successors, FD is 128256
        via Connected, Loopback11
P 10.1.100.0/24, 1 successors, FD is 28160
        via Connected, FastEthernet0/0
P 10.1.200.0/24, 2 successors, FD is 40514560
        via 10.1.100.1 (40514560/40512000), FastEthernet0/0
        via 10.1.100.2 (40514560/40512000), FastEthernet0/0

Le successor de R3 pour 10.1.1.1 est 10.1.100.1 via la FastEthernet0/0.
Etant donnée qu’il n’y a pas de Feasible Successor (FD), R3 va devoir envoyer des paquets QUERY à ses voisins, et attendre de recevoir un REPLY avec une route. Le seul voisin restant à R3 étant R2, R2 enverra un paquet REPLY à R3, et R3 établira une nouvelle route vers 10.1.1.1 passant par R2, le lien série, puis R1.

Le débug suivant montre bien la table de routage de R1, ainsi que les Paquets EIGRP reçus par R2 pendant la convergence.

Output:

R1#sh ip route eigrp
     10.0.0.0/24 is subnetted, 5 subnets
D       10.1.3.0 [90/156160] via 10.1.100.3, 00:16:37, FastEthernet0/0
D       10.1.2.0 [90/156160] via 10.1.100.2, 00:16:32, FastEthernet0/0
D    192.168.100.0/24 [90/156160] via 10.1.100.3, 00:16:37, FastEthernet0/0

R1#conf t
R1(config)#int f0/0
R1(config-if)#shut

*Jan 12 22:40:27.127: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.100.2 (FastEthernet0/0) is down: interface down
*Jan 12 22:40:27.159: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.100.3 (FastEthernet0/0) is down: interface down
*Jan 12 22:40:28.783: %LINK-5-CHANGED: Interface FastEthernet0/0, changed stateto administratively down
*Jan 12 22:40:28.787: %ENTITY_ALARM-6-INFO: ASSERT INFO Fa0/0 Physical Port Administrative State Down
*Jan 12 22:40:29.783: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down

R1(config-if)#do show ip route eigrp 

     10.0.0.0/24 is subnetted, 5 subnets
D       10.1.3.0 [90/40642560] via 10.1.200.2, 00:00:05, Serial1/0
D       10.1.2.0 [90/40640000] via 10.1.200.2, 00:00:06, Serial1/0
D       10.1.100.0 [90/40514560] via 10.1.200.2, 00:00:06, Serial1/0
D    192.168.100.0/24 [90/40642560] via 10.1.200.2, 00:00:05, Serial1/0

R2#deb eigrp packets
EIGRP Packets debugging is on
    (UPDATE, REQUEST, QUERY, REPLY, HELLO, IPXSAP, PROBE, ACK, STUB, SIAQUERY, SIAREPLY)
[...]
*Jan 12 22:48:47.779: EIGRP: Received QUERY on Serial1/0 nbr 10.1.200.1
*Jan 12 22:48:47.783:   AS 1, Flags 0x0, Seq 67/55 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0

*Jan 12 22:48:47.803: EIGRP: Enqueueing REPLY on Serial1/0 nbr 10.1.200.1 iidbQun/rely 0/1 peerQ un/rely 0/0 serno 38-38
*Jan 12 22:48:47.819: EIGRP: Requeued unicast on Serial1/0
*Jan 12 22:48:47.827: EIGRP: Sending REPLY on Serial1/0 nbr 10.1.200.1
*Jan 12 22:48:47.831:   AS 1, Flags 0x0, Seq 57/67 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1 serno 38-38
[...]
*Jan 12 22:48:57.759: EIGRP: Received QUERY on FastEthernet0/0 nbr 10.1.100.3
*Jan 12 22:48:57.759:   AS 1, Flags 0x0, Seq 37/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1
*Jan 12 22:48:57.791: EIGRP: Enqueueing REPLY on FastEthernet0/0 nbr 10.1.100.3 un/rely 0/1 peerQ un/rely 0/1 serno 42-42
*Jan 12 22:48:57.795: EIGRP: Requeued unicast on FastEthernet0/0
*Jan 12 22:48:58.091: EIGRP: Sending REPLY on FastEthernet0/0 nbr 10.1.100.3
[...]

R1(config-if)#no shut
*Jan 12 22:40:42.419: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.100.3 (FastEthernet0/0) is up: new adjacency
*Jan 12 22:40:42.595: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.100.2 (FastEthernet0/0) is up: new adjacency
*Jan 12 22:40:43.047: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Jan 12 22:40:43.051: %ENTITY_ALARM-6-INFO: CLEAR INFO Fa0/0 Physical Port Administrative State Down
*Jan 12 22:40:44.047: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up


Sur ce schéma, vous pouvez voir que le traffic passe par R2, quand l’interface F0/0 de R1 est Down.

Voici le ping depuis R3 pendant tous ce temps, avec le nombre de paquets perdus pendant la convergence (QUERY/REPLY/Apprentissage de la nouvelle route).

R3#ping 10.1.1.1 rep 10000

Type escape sequence to abort.
Sending 10000, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!......
*Jan 12 22:22:28.343: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.
tEthernet0/0) is down: holding time expired.!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
*Jan 12 22:23:41.039: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.
tEthernet0/0) is up: new adjacency.!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Demain, Labo sur EIGRP Load-Balancing, suivi de fiches théoriques sur EIGRP…

Benoit

Network engineer CCIE #47705, focused on R&S, Data Center and SDN.

More Posts - Website

Follow Me:
TwitterLinkedIn

6 Comments

  1. Marie-Laure 13 janvier 2010

    ca me rappel ma révision de CCNA!

    Je vais probablement continuer encore un petit peu sous packet Tracert, a moins que tu m’aides un peu avec dynagen ;D

  2. alex 13 janvier 2010

    pas d’sparsemem, de ghostios et d’idlepc ?

  3. alex 13 janvier 2010

    amaylol! stop commentay tout le temps en même temps que toi!

  4. Benoit 13 janvier 2010

    @alex: ça marche sans !
    @ML: On verra ça un de ces 4 !

    Et c’est vrai que vous êtes mes plus fidèles commentateurs ! Merci.

  5. Marie-Laure 13 janvier 2010

    au plaisir …
    je suis tes tweets aussi!

  6. Moindjié 9 juillet 2012

    merci pour l’astuce,je vais essayer ça! mais je vais savoir comment on relie 2reseaux differents sur 2fenetres differents de packet tracert pour que un ordi du 1er Rx dans la 1ere fenetre puisse pinguer un autre ordi du 2eme Rx de la 2eme fenetre merci bcp!!

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Vous pouvez utiliser ces balises et attributs HTML : <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>